[Exchange] Timeout error on Hosted Exchange OWA and Outlook client
Incident Report for CloudNordic
Resolved
This afternoon we experienced an outage on Outlook and OWA client mailboxes, which is no longer an issue, as the task has been resolved and all mailboxes are fully functional again.

The issue was caused by shutdown of communication between our firewall and OWA servers, which service the Outlook client access, so both types of services ceased to work.

The reason for the error was due to malformed http requests sent to our OWA webservers from the Internet, which Outlook clients also communicates through, which was stopped immediately by our antivirus solution.

Our antivirus system automatically reopened the access to OWA and thus Outlook clients once the attack ceased.

According to our system engineers our POP3/IMAP services were not affected by this timout.

Solution: Hosted Exchange OWA and Outlook

Start: 25-05-2021 @ 16:01 CET
End: 25-05-2021 @ 16:20 CET

We apologize for any inconvenience this incident may have caused.

Kind regards from the CloudNordic Helpdesk & Support Team
Posted May 25, 2021 - 16:44 CEST
Monitoring
We are currently experiencing a timeout on our Hosted Exchange OWA function, due to a communication error between the firewall service and the OWA servers, which affects login access to OWA and Outlook clients for both Exchange, POP3 and IMAP.

We are working hard to resolve the issue and will keep you posted on resolving the matter.

Start: 25-05-2021 at 16:01 CET

End: 25-05-2021 at 16:30 CET (expected)

We apologize for any inconveniences and disruptions this may cause.

Kind regards from the CloudNordic Helpdesk & Support Team
Posted May 25, 2021 - 16:13 CEST
This incident affected: CloudNordic services (Hosted Exchange).