[Hosted Exchange] OWA and Outlook issue
Incident Report for CloudNordic
Resolved
The issue has been identified to be one of the major mail databases.

It was resolved around 9:30 Copenhagen time.

We apologize for any inconvenience this incident may have cause and are working hard to resolve the issue as fast as possible.
Posted May 23, 2023 - 09:52 CEST
Identified
We are aware of the current issue with the Hosted Exchange service, and are working resolving the issue.

We apologize for any inconvenience this incident may have cause and are working hard to resolve the issue as fast as possible.

CloudNordic Helpdesk & Support Team
Posted May 23, 2023 - 01:22 CEST